[Resolved] “BrowserslistsError: Unknown version 92 of android” while ng build

After upgrading the Angular project version from 12 to 13, you notice a build error while executing the “ng build” CLI command on the Angular project.

This Angular post is compatible with Angular 4 upto latest versions, Angular 7, Angular 8, Angular 9, Angular 10, Angular 11, Angular 12 and Angular 13

The error says: “BrowserslistsError: Unknown version 92 of android”

This error occurs due to an obsolete list of the supported browser kit OS environments.

Solution

There is a simple solution to it:

Just execute the following command to update the list of Browsers lists in the package-lock file:

npx browserslist --update-db

After executing the above command, you will see the list of updated supported browsers list like below:

npm install caniuse-lite

“caniuse-lite has been successfully updated”

Leave a Reply

Your email address will not be published. Required fields are marked *